Author Topic: working on raspberry pi 3  (Read 2690 times)

mike_bee

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
working on raspberry pi 3
« on: November 19, 2016, 04:03:09 PM »

I got laser shark up and running with pretty good results on a raspberry pi 3. I was even able to use Openlase (minus the image tracing features) with good results.

Here is a link to some test results on a glow-in-the-dark tile using the Lasershark displayimage script.

https://youtu.be/hej8FmUhptk

« Last Edit: November 19, 2016, 08:35:57 PM by mike_bee »

Macpod

  • Administrator
  • Full Member
  • *****
  • Posts: 177
  • Karma: +3/-0
    • View Profile
Re: working on raspberry pi 3
« Reply #1 on: November 21, 2016, 10:58:03 PM »
Apologies Mike, it seems my forum notifications didn't work for this post.

Glad to hear it is working well with the pi 3. It certainly is a little faster than the 1st gen one, isn't it?

Ah and I see you found the image display app too! I've been wanting to try that with a phosphor screen but haven't had the time (I just used a long exposure feature of my camera when testing the app). Looks neat!
« Last Edit: November 21, 2016, 11:00:20 PM by Macpod »

maso27

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: working on raspberry pi 3
« Reply #2 on: February 15, 2017, 11:32:21 AM »
@mike_bee
I just started working on getting LaserShark up and running, and have run into the issue of compiling openlase for a Raspberry Pi.

If it's not too complicated, how did you go about removing the image tracing features to get it to compile?

Macpod

  • Administrator
  • Full Member
  • *****
  • Posts: 177
  • Karma: +3/-0
    • View Profile
Re: working on raspberry pi 3
« Reply #3 on: February 15, 2017, 06:58:08 PM »
You will need to modify the tools/CMakeLists.txt to comment out the lines that build this as so:
https://github.com/marcan/openlase/blob/master/tools/CMakeLists.txt

Afterwards delete your build directory and re-run through the build steps :)

maso27

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: working on raspberry pi 3
« Reply #4 on: February 16, 2017, 11:31:54 AM »
Thanks, but that's already commented out.

I found that I could disable tracer by editing openlase/CMakeLists.txt and changing the Y to N in this chunk:

Code: [Select]
if(NOT DEFINED BUILD_TRACER)
  set(BUILD_TRACER "Y" CACHE BOOL "Build the image tracer (x86 only)" FORCE)
endif()

Problem solved!

(Now I just have to learn how to use it...)