Author Topic: Lasershark help  (Read 3021 times)

leob

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Lasershark help
« on: October 04, 2015, 11:56:10 AM »
Hello!

I'm having some issues with drivers, maybe someone has already got the same problems. Installing separete drivers for Lasershark interfaces (interface 0, 1, 2) nothing works.

"circle maker" test (http://macpod.net/electronics/lasershark/images/windows/lasershark_stdin_cmdline.jpg) doesnt work, it appears "error finding USB device", and also CW isn't able to move the galvos anyway (although LaserShark appears  on CW).


Then, using ZADIG (http://zadig.akeo.ie/), I have tried to install libsusb driver for LaserShark as a composite device. In this case "circle test" works, showing a very nice simetric circle. But I'm still stuck inside CW, that never makes the galvos shake.

I'm quite convinced that this is a driver/USB issue.

I am using Win 8.1 64bit, usb 3.0... but I've tried also in an older win XP, the situation is the same.

Complementary, I'm receiving an error message telling that a "composite device" may have problems running on USB3.0.

did anyone have similar issue?

Thanks for any support



Macpod

  • Administrator
  • Full Member
  • *****
  • Posts: 177
  • Karma: +3/-0
    • View Profile
Re: Lasershark help
« Reply #1 on: October 04, 2015, 05:29:16 PM »
Hello!

I'm having some issues with drivers, maybe someone has already got the same problems. Installing separete drivers for Lasershark interfaces (interface 0, 1, 2) nothing works.

"circle maker" test (http://macpod.net/electronics/lasershark/images/windows/lasershark_stdin_cmdline.jpg) doesnt work, it appears "error finding USB device", and also CW isn't able to move the galvos anyway (although LaserShark appears  on CW).


Then, using ZADIG (http://zadig.akeo.ie/), I have tried to install libsusb driver for LaserShark as a composite device. In this case "circle test" works, showing a very nice simetric circle. But I'm still stuck inside CW, that never makes the galvos shake.

I'm quite convinced that this is a driver/USB issue.

I am using Win 8.1 64bit, usb 3.0... but I've tried also in an older win XP, the situation is the same.

Complementary, I'm receiving an error message telling that a "composite device" may have problems running on USB3.0.

did anyone have similar issue?

Thanks for any support

Hi leob,

Circlemaker.exe/lasershark_stdin.exe did not originally work because you had not installed the drivers. As you have found, once the drivers were installed circlemaker.exe and lasershark_stdin.exe worked as expected.

Given that circlemaker.exe/lasershark_stdin.exe work now, why do you think there is a USB driver issue? CW should use the same drivers thus if anything this should rule out a problem with usb/usb drivers and instead suggest there is an issue with your CW or your CW configuration.

And as a side note, cheaper and older usb 3.0 chipsets are notorious for having issues. Often times this can be solved by using a usb 2.0 hub or simply changing computer ports. Usually those on the back vs those on the front of the computer case have fewer issues.