Author Topic: Trouble in "cmake .." with "libavresample" to use /playvid  (Read 16708 times)


  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Trouble in "cmake .." with "libavresample" to use /playvid
« on: April 07, 2014, 09:47:30 PM »
I'm still trying to figure out what this means, but the problem is referenced either here in the install directions, or it's impossible because I found a changelog by Kamal that said he modified the install to work if libavresample is not available.

The following are needed to allow everything to compile.. hmm looks like the cmake scripts should be updated to look for these dependencies:

sudo apt-get install libavformat-dev libavdevice-dev


Hi, I know I've been coming here a lot but thanks for your help.
I'd like to get playvid running, and when I perform 'cmake ..' in the build directory of openlase, I'm told it won't compile because of something about libavresample being unknown. I'll attach the terminal output.
Code: [Select]
-- Found FFMPEG: /usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/ /usr/include
CMake Warning at CMakeLists.txt:36 (find_package):
  By not providing "Findlibavresample.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "libavresample", but CMake did not find one.

  Could not find a package configuration file provided by "libavresample"
  with any of the following names:


  Add the installation prefix of "libavresample" to CMAKE_PREFIX_PATH or set
  "libavresample_DIR" to a directory containing one of the above files.  If
  "libavresample" provides a separate development package or SDK, be sure it
  has been installed.

-- Will build tracer (SSE2 version)
-- Will NOT build playvid (FFmpeg or libavresample or tracer missing)
-- Will NOT build qplayvid (Qt4 or FFmpeg or libavresample or tracer missing)
I don't know if it's related but there's a thread about libavresample in the comments here-
"I see now that once ‘libavresample-dev’ is installed, other packages are then marked for update. Doing an update, either through the Update Manager or by ‘aptitude dist-upgrade’, etc., will then insist on uninstalling ‘libavresample-dev’ because of dependency issues. Ouch"

I did my software updates and searched the synaptic package manager for libav and installed everything that looked relevant. Then I downloaded version of libav 9.12 from the web and dragged a folder from there called libavresample to /usr/include (this is a place where some folders with libav in them are) and tried that but nothing worked. I removed the folder when it didn't work.

also is there any easy reference for to replicate the tunnels marcan used towards the end of his demo?

« Last Edit: April 08, 2014, 04:14:31 AM by Fstill »


  • Administrator
  • Full Member
  • *****
  • Posts: 179
  • Karma: +3/-0
    • View Profile
Re: Trouble in "cmake .." with "libavresample" to use /playvid
« Reply #1 on: April 10, 2014, 09:37:20 AM »
Cmake is a build system. Before it tries to build components it tries to verify the needed libraries are available to build a component. If that component is not available then that portion of the system is not built. Cmake is working as intended here.

Playvid was made before the ffmpeg/libav group split which you can read about here:

To try to make this easy to understand at the risk of technicalities:
The package set mint uses is libav and the components that played used are no longer compatible which is why even if you add these components playvid will not build. You would need to drop back to say... ubuntu 10.04 where ffmpeg is still used to get this working.

I'll get to it one day but I get a ton of software requests and each one takes time to make/correct. :)
If someone else wanted to look at this they should check out how libav factioned this off and then add some conditional code to account both for people with ffmpeg and then those that use libav.


  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: Trouble in "cmake .." with "libavresample" to use /playvid
« Reply #2 on: April 11, 2014, 02:11:55 AM »
All right, thanks so much for the reply! I appreciate it.