Macpod LLC: Forums

Support => LaserShark Support => Topic started by: zhang on January 08, 2019, 01:04:37 AM

Title: Galvos no movement need help
Post by: zhang on January 08, 2019, 01:04:37 AM
Hello Nelson, this year I finally have time to do something on openlase with Lasershark.
But there seemed to be something wrong with the hardware or the install steps. (I first do it on WIN10)
 The laser can work under the TTL signal, but only the galvos no movements at all. I just want to know where is wrong. (I did make the lasershark composite device with Zag.)

(IMG2 and IMG3 are two different PC with WIN10.IMG4 is what it shows when I open the Zag the second time.)
Title: Re: Galvos no movement need help
Post by: Macpod on January 08, 2019, 10:23:28 PM
Hi Zhang,

That is an interesting daughterboard between the lasershark and galvo amplifiers. I have not seen this before.

It certainly looks like the LaserShark is successfully connected in the app. If it was not you would not be able to read the firmware version, ringbuffer sample count, etc.
I see that you also say that ttl signals work so it sounds like you can turn on and off a connected ttl laser suggesting the software<->lasershark link is working

While it is hard to tell from the image, it does appear as if you have connected the X and Y connections to the associated pins on the daughterboard correctly.

I am unable to read the text on the daughterboard which the power cable is connected to. Are you confident it should go there? Are there any LEDs on the galvo amplifier board to indicate it is successfully receiving power? Also, are the heatsinks warm to the touch? Even at idle the heatsinks should feel warm to the touch usually.

Title: Re: Galvos no movement need help
Post by: zhang on January 09, 2019, 01:37:11 AM
Hello Nelson,

Thanks for your reply. And the laser can be on/off depending on the app.

But the galvos amplifiers have no movements. The left LED is off and the right LED is on. But when I first used this, I used to think the 15V+- pins on the board are the power pin by mistake, so I used a 15V PSU to input the power to it, and only the LED on left side turned on. But then I found it wrong and use a 24V PSU to power it through the pins on the daughterboard. Was this action broken the amplifier down?

And the heatsinks are not so warm even if turn on the power with the LED on.
Or can it be something wrong with the 2.54mm 3pin cable? As you can see, the ones we bought can't match them on the board perfectly. But I've changed them for 3times and make sure the X+ matches the X+, .etc.

And I'm now trying the circle example on Ubuntu 16.04, and the galvos only still not work.
Seems to be something wrong with galvos or the connections between lasershark and daughterboard.


------------modified again----------------
And now the galvos finally moves and two of the LEDs got light on. But, it may rotate even if I have not open the .exe yet.(Maybe the signals in buffer?) And here is the video.
And when I turn on the .exe, the left LED turns OFF and galvos mirror no longer work... I don't know what just happened..
Title: Re: Galvos no movement need help
Post by: Macpod on January 10, 2019, 01:46:20 AM
Thank you for these pictures and video.

Often times galvo boards will have two 3-pin connectors on them.
- One is used for power INPUT from a power supply
- The other is a power OUTPUT. This is used to provide a +/-15v power supply to an external DAC (Digital-to-Analog Controller) board.

If you attempted to power the galvo board via the OUTPUT power connector it is possible this could have damaged your board. It looks like the LEDs are intended to indicate if you have +15v and -15V. If neither or only one are not turning on this is not a good sign.

If you connect a multimeter to the the center pin (gnd) and then the side pins of the +/-15v connector what does it read? it should be a stable value close to  +15V on one side and -15V for the other.

Do you have a datasheet for your galvo kit?
What did you do to cause both LEDS to turn on?

In the video, were you running the circle_maker app or was this just with them plugged in. It looks like they are slowly turning clockwise/counterclockwise but slower than I believe they should (unless you modified the code). The galvos should not make that buzzing noise, that means a spurious signal is being generated or the galvo amp circuit is damaged. It could also mean a bad/intermittent connection.
Title: Re: Galvos no movement need help
Post by: zhang on January 13, 2019, 07:43:01 AM
Hello Nelson:

Thanks for your reply!

Using the multimeter, it shows that the +15V side is normal but the -15V side only outputs -0.7V. :( How I made both the LEDs on is just plug them in. After 5s random turning, the left LEDs turns off with a big sound, and the galvos mirrors no longer move.

Here is the Galvos kit ( And there seems no full datasheet or Galvo kit provided by the seller and little information about the kit.
Sad to say but it seems amplifiers were damaged. Just did a mistake reading the datasheet "working Power Supply: ±15VDC" and then plug it onto the 15+V OUTPUT 3PIN connections. Any remedial measure? Or to buy another set.
Title: Re: Galvos no movement need help
Post by: Macpod on January 13, 2019, 03:38:20 PM
If you also heard a loud noise it is likely something "let out the magic blue smoke". That's a shame as this was an expensive kit.

The good news about this situation is that there are generally no embedded controllers on the boards. If you have an electrical background and are strapped for cash you could try and identify potentially bad parts (i.e. the -15v regulator which is one of the 3-pin chips screwed to one of the heatsinks) and any op-amps/resistors/etc.

The power supply likely isn't bad (but you could check to make sure it is still  outputting +-24v). It is possible the galvos are fine too which means you may just need to replace the galvo amplifier board itself vs everything.
Title: Re: Galvos no movement need help
Post by: zhang on January 28, 2019, 11:40:36 PM
Hello Nelson:

sorry for replying so late for some reasons.

And it didn't work well since we try to do repairment to the board of kit and had to buy a new one. Also, thank you for your help, and we have to wait for another 1 month.

Another teacher shows interest in laser and wants to do something with it on a laserboard but it seems no stack now(perhaps you are out for business?), and it would be nice if we can get it by next month.

Title: Re: Galvos no movement need help
Post by: Macpod on January 28, 2019, 11:58:39 PM
I'm still in business.  8)

Sorry to hear that you could not repair your amplifiers. I still believe this is possible however troubleshooting the problem could be time consuming if it isn't as simple as a capacitor or the regulators.

We had a company buy out our stock of LaserSharks to integrate into their own product. I am in the process of having more LaserShark units fabricated but this takes time, especially during this time of the year. The new boards will likely be in within 1-2 months.

I have one remaining unit. If you are interested in this one please email me.
Title: Re: Galvos no movement need help
Post by: zhang on February 08, 2019, 04:59:25 AM
Hello Nelson,

And we finally get the new board of galvos, but it seems upset that the previous problem might not be the board of galvo.

When we set them up and do nothing, both of the LEDs are on and seems no problem, but the time we run the draw_circle test, one of the LEDs turns off with an obvious sound like pressing a switch off. And now I'm very confused about what I should do next. The output voltage of TTL 2 pins are 5V but the ones on 3 pins(X,Y) are not stable , varying from -0.1mV to -150mV.
And to confirm, I want to know that is it necessary to install the JACK service even if I just not run the OPENLASE but the draw_circle test, right?
And if I want to configure the OPENLASE, I need to install
3.Compiling and Using the Lasershark Jack Host Application (for use with OpenLase) part in
We are not so familiar with the hardware but just want to know more about it!
Title: Re: Galvos no movement need help
Post by: Macpod on February 09, 2019, 07:35:29 PM
Hi Zhang,

JACK is only required for running OpenLase and lasershark_jack. The galvo/laser control data is sent using the JACK audio daemon here. You do not need to do steps 1, 2, 3 if you just want to use lasershark_stdin.

You do not need JACK or OpenLase to use lasershark_stdin, lasershark_stdin_circlemaker, or lasershark_stdin_displayimage.

Did you replace both the galvo amplifiers and galvos or just the galvo amplifier boards?
What component is causing the clicking noise the clicking?
What are you measuring the output voltage on?

Title: Re: Galvos no movement need help
Post by: zhang on February 10, 2019, 04:31:11 AM
Hi Nelson,

Thanks for your reply!  ;)

There are no more stacks of the same galvo kit we bought at first and we are worried about that if the board doesn't match the mirrors, so we replace them including the mirrors, but it seems no change.

And the noise is from the amplifier but hard to tell exactly which part on the board.
And the voltage I just measured is the output-pins on lasershark-board, wanting to confirm that whether the output from lasershark-board works well or not.

Here is the video(sound may not record):
And I found that the LED will turn off automatically after a period of time(about 20s?) if I do nothing, just like the situation as I post here at Jan 09.
Title: Re: Galvos no movement need help
Post by: Macpod on February 10, 2019, 01:53:04 PM
Hello Zhang,

Ok, so you have replaced the galvos themselves as well as the galvo amplifiers.

When circlemaker is running the voltages quickly swing one direction and then the other. You would not be able to measure the Lasershark X and Y channel voltages with a voltmeter, you would need to use an oscilloscope. Measuring with a voltmeter would just show a a varying voltage.

I do not hear a switching/clicking noise in the video.

I do hear a "fluttering" noise which sounds like the galvos rotating back and fourth as expected. The galvos do not move a significant amount so it is best to test with a low power laser (i.e. a laser pointer) to identify if the galvos are moving.

If you were unaware the galvos do not rotate 360 degrees when running. Instead they turn clockwise/counterclockwise by a small degree (30-45 degrees max usually) very quickly like the needle of an analog voltmeter.

Title: Re: Galvos no movement need help
Post by: zhang on March 19, 2019, 07:48:42 AM
Hello Nelson:

Sorry for delaying so long for returning to China.

The fluttering noise may be the sound of fans attached on laser.

Situations of now:

1. When we only plug in the power supply of the galvos kit, the mirrors will rotate in small angle for unknown reasons. And after 2mins, one of the two LEDs will turn off automatically with a big "click" sound, meanwhile, the mirrors stop movement.
video1 (

2. The time when I run the demo of circle_maker or the Openlase samples through the Jack, the laser will turn on or off perfectly but the galvos mirrors will be down immediately.
video2 (

Or maybe it is the galvo kits' problem (new ones are almost same galvo kit as before)?  :(

Title: Re: Galvos no movement need help
Post by: Macpod on March 21, 2019, 12:39:18 AM
Hello Zang,

For video1, it looks like you have everything connected but you are not running the lasershark_stdin app? I am assuming this because it looks like all wires are connected in the video and I see green power led and green usb led of the lasershark are on.

If everything were functioning correctly the lasershark would print a continuous signal in this state. The fact the galvos are moving is a problem.

In video2 it looks like the power LEDs on the galvo amplifier board are pulsing. Is this a camera artifact or is this really happening?  This shouldn't happen nor should they be turning off. The click sounds like the laser mirror is quickly rotating to the absolute max point (which is not something you wan't to have happen.)

Either there is still an issue with the galvo and amplifiers, the wiring is incorrect, or the amplifiers/dac have been damaged on the lasershark. It is a new galvo kit so the galvo and amplifiers shouldn't be damaged yet.. from before it looks like you have the galvo x and y channels wired correctly. Can you validate with the seller the orientation of the ribbon cable?
Title: Re: Galvos no movement need help
Post by: zhang on March 24, 2019, 01:11:34 AM
Actually, we received the first reply from the seller and described what problem we met, but it seems to take a little time before the next reply. Hoping to get some hint   :P
Title: Re: Galvos no movement need help
Post by: zhang on April 08, 2019, 10:47:32 PM
Hello Nelson,

After reading the advice from the maker, we found that we did something wrong in connecting the board to the PSU, and now it is OK!! The galvos mirrors rotate as expected!! Also, thank you for your help!!