Author Topic: Trouble working with playilda  (Read 6723 times)

landshark

  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Trouble working with playilda
« on: April 04, 2014, 01:44:31 AM »
Hi, I've tried a lot of things but can't get playilda to play .ild files.
-In the usage the the argument sent to resample really important?

I noticed the .c file makes references to some plugs in Jack I don't have, for example "out_z" and "out_w." I tried /* */ them out of the code but that didn't help, and I noticed that naturally there's a single line commented out with // in the playilda at the kamal fork, and I deleted the comments but that didn't help. I also added the missing plugs into jack and tried that but to no avail.

When I run it my terminal gives some text and then nothing happens. I get this:
"./playilda  /home/finley/Desktop/American_Flag_Float.ild
Playing back at 30000 pps
Got 3D frame, 1635 points
Resampling 30000 -> 30000
the maximum buffer size is now 640"

and I looked in the code that calls that last print message, it's inside
int bufsize (nframes_t nframes, void *arg){ ...}

And since there is only one other 'bufsize' in code, I know where it's getting called, which is this call:
   jack_set_buffer_size_callback (client, bufsize, 0);

and immediately after that is this line:
   jack_set_sample_rate_callback (client, srate, 0);

Which means that srate should be called, the way bufsize was, but I never see the text that is inside srate:

int srate (nframes_t nframes, void *arg)
{
   rate = nframes;
   printf ("Playing back at %u pps\n", rate / divider);
   return 0;
}

I've also tried a few different ilda's. If I download an .ild
and change it's name to one used in marcan's demo and put it in that folder, it shows up though. But not on playilda. I've tried passing arguments so things are re-sampled at random numbers, and I can start and stop ./simple in another terminal without effecting the nothing going on in the playilda one. Do you happen to know how to fix this or what might be wrong? Thanks. I'm sorry this is such a long question.


(I get this message (with no errors) when I run playilda in jack 
22:32:41.563 JACK connection graph change.
22:32:41.650 JACK active patchbay scan...
22:32:41.652 save patchbay: output:out_x -> lasershark:in_x checked.
22:32:41.654 save patchbay: output:out_y -> lasershark:in_y checked.
22:32:41.655 save patchbay: output:out_r -> lasershark:in_g checked.
22:32:41.658 save patchbay: output:out_g -> lasershark:in_r checked.
22:32:41.660 save patchbay: output:out_b -> lasershark:in_b checked.
22:32:41.662 JACK connection change.
22:32:41.864 JACK active patchbay scan...
22:32:41.868 save patchbay: output:out_x -> lasershark:in_x checked.
22:32:41.870 save patchbay: output:out_y -> lasershark:in_y checked.
22:32:41.872 save patchbay: output:out_r -> lasershark:in_g checked.
22:32:41.874 save patchbay: output:out_g -> lasershark:in_r checked.
22:32:41.876 save patchbay: output:out_b -> lasershark:in_b checked.
Thu Apr  3 22:32:41 2014: New client 'playilda' with PID 7906
)
« Last Edit: April 04, 2014, 06:29:46 AM by Fstill »

Macpod

  • Administrator
  • Full Member
  • *****
  • Posts: 170
  • Karma: +3/-0
    • View Profile
Re: Trouble working with playilda
« Reply #1 on: April 04, 2014, 07:10:48 PM »
You need to add and connect sockets for playilda. Please see the following images for my setup. Sorry that the test ilda is so dim.


Note: The second parameter is the lida rate for the file. I probably should have run that as
Code: [Select]
./playilda ../../test_patterns/ILDA12K.ild 12000
For this example it will make it just look flickery. For other multi-frame ilda files it should slow things down... without it the animation would play super fast!

Side note: I haven't played around with the ilda player much and haven't tried out any multi-frame files yet. Let me know how that works out for you if you try.
« Last Edit: April 04, 2014, 07:28:55 PM by Macpod »

landshark

  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: Trouble working with playilda
« Reply #2 on: April 05, 2014, 08:27:50 AM »
Thanks so much for the help! Im really luck you keep helping me. Thank you. It's playing ilda files now. It only seems to be playing the beginning of the ilda files I download though, for instance, in the "hands.ilda" file here:
http://lasergraffiti.weebly.com/rgb-laser-ild-animation-downloads.html
It loads the hands but and continues to draw them but they never rotate. Or in "austday2.ild" it will draw the kangaroo but it never jumps.

I only have one laser color, that I selected in the output app... this wouldn't effect it would it? Is this just how playilda is now do you think?

Thanks,
Finley

Macpod

  • Administrator
  • Full Member
  • *****
  • Posts: 170
  • Karma: +3/-0
    • View Profile
Re: Trouble working with playilda
« Reply #3 on: April 05, 2014, 07:23:44 PM »
The fact that it is only playing the first frame would not be affected by the number of colors you utilize.

This is either a bug or a limitation of the playilda app which will need to be looked into. This weekend and this coming week will be especially busy for me. After these I might have to take a look.

Stimpy

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: Trouble working with playilda
« Reply #4 on: April 05, 2014, 08:13:06 PM »
I got the same problem with the ilda files they not run only the first frame and then they stop. That is software problem.

landshark

  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: Trouble working with playilda
« Reply #5 on: April 06, 2014, 06:43:41 AM »
Sounds good. Thanks!