Recent Posts

Pages: 1 ... 8 9 [10]
3D Printers / Re: Any pointers for making this work in 2017?
« Last post by maso27 on February 27, 2017, 06:34:26 PM »
I got libjson-rpc-cpp to build and install on raspberry pi.

(notes for posterity):
Code: [Select]
sudo aptitude install libargtable2-dev libcurl4-openssl-dev libmicrohttpd-dev doxygen libjsoncpp-dev
tar -xzvf v0.7.0.tar.gz
  --THEN follow the build instructions at --
Their current git pull won't build for raspbian so I had to grab an earlier release.  I've reported an issue.

But I'm still having the following error with lasershark_3dp:
Code: [Select]
abstractlasersharkjsonserver.h:8:25: fatal error: jsonrpc/rpc.h: No such file or directory
Any ideas?
3D Printers / Re: Any pointers for making this work in 2017?
« Last post by maso27 on February 27, 2017, 04:40:20 PM »
Thanks for responding Macpod.

My initial intent for this project was to focus more on the hardware than the software side of things.  As I learn more it appears I need to adjust my expectations.

It's nice to hear a little bit about what's intended with lasershark_3dp.  Compiling it for the pi has been laborious due to libjson-rpc-cpp issues, and when I couldn't find any recent info I began to get frustrated.

I'll say that I make up for my lack of coding skills with tenacity, so I'll see if I can think of anything to further my desires.
3D Printers / Re: Any pointers for making this work in 2017?
« Last post by Macpod on February 25, 2017, 09:35:34 PM »
Hi Maso27,

Creation Workshop is software by Envision Labs so if you want support for this you will need to contact this company. If they have gone closed source that is disappointing to hear but understandable. Developing 3d-printer software takes a significant amount of time both to write the software and support it.

lasershark_3dp is pre-alpha code as mentioned on the github page. I developed it under Linux Mint 14 and it should compile just fine on other linux platforms provided you have installed the proper support libraries. Windows is not supported at the moment.

The objective of lasershark_3dp was to act as a "print server". You would attach a raspberry pi to a lasershark, and then run a web server as well as the lasershark_3dp server on the pi.

The webserver on the pi would host a html5/javascript site that would allow you to upload stl files and slice them. These would then be sent in json-encoded png layers over a network connection to the lasershark_3dp server to print.

The front end does not exist yet. If you are up to the challenge of writing this I can answer protocol questions.

If you are only interested in this from an end-user perspective you may want to consider finding another 3d slicer package that will export png layers. You can then use a conglomerate of lasershark_stdin_display_image, lasershark_stdin, a command line app to control your stepper motors, and finally a script to loop through all the layers.

3D Printers / Any pointers for making this work in 2017?
« Last post by maso27 on February 25, 2017, 02:27:47 PM »
I have begun an SLA printer project with lasershark, and am finding nothing but dead ends.

I have established that Creation Workshop disappeared from the open-source scene sometime in 2014.  I've found an old lasershark plugin for it but haven't had any luck making it work with the versions I can scrounge from forums.

Trying to compile lasershark_3dp either for raspberry pi or for Windows 10 x64 has been less than straightforward, and videos from Stimpy, who appears to be one of the few who got it working, are missing or else impossible to make out due to poor video resolution.

So, has anyone got any tips?  Have people just given up on laser-based SLA printers?
LaserShark Support / Re: working on raspberry pi 3
« Last post by maso27 on February 16, 2017, 11:31:54 AM »
Thanks, but that's already commented out.

I found that I could disable tracer by editing openlase/CMakeLists.txt and changing the Y to N in this chunk:

Code: [Select]
  set(BUILD_TRACER "Y" CACHE BOOL "Build the image tracer (x86 only)" FORCE)

Problem solved!

(Now I just have to learn how to use it...)
LaserShark Discussion / Re: lasershark_display_image
« Last post by Macpod on February 16, 2017, 02:59:23 AM »
Thanks for re-posting your questions here.

1. No, ttl modulation is not required. You can specify in the settings of lasershark_displayimage if ttl should be used (monochrome), if only one analog color should be used (greyscale), or if all channels should be used (rgb)

2. You cannot make the galvo angle range smaller via the software. If you need this to occur you should scale down the image from being 4096 bits wide to your desired width.

3. OpenLase has an .ild player called playilda. This is present in the tools directory. It is limited but will play some ild files.

General comment:
If you run lasershark_displayimage with the -h flag (don't pipe this output to lasershark_stdin of course). you can see what options are available for tweaking.

Hope that helps!
LaserShark Discussion / lasershark_display_image
« Last post by nicobux on February 15, 2017, 10:05:30 PM »

The scanner appears to move horizontally very quickly, and vertically very slowly. Not sure how to get the image I want.

Some questions:

1. Does _displayimage rely on ttl modulation to draw images?
2. What parameter should I change in _displayimage to make the galvo angle range smaller? In other words I want to limit the DAC output to something like 1000-3000 instead of 0-4095. 3. Is there software for displaying .ild with Lasershark?
LaserShark Support / Re: working on raspberry pi 3
« Last post by Macpod on February 15, 2017, 06:58:08 PM »
You will need to modify the tools/CMakeLists.txt to comment out the lines that build this as so:

Afterwards delete your build directory and re-run through the build steps :)
LaserShark Support / Re: working on raspberry pi 3
« Last post by maso27 on February 15, 2017, 11:32:21 AM »
I just started working on getting LaserShark up and running, and have run into the issue of compiling openlase for a Raspberry Pi.

If it's not too complicated, how did you go about removing the image tracing features to get it to compile?
General Discussion / Re: Getting to 64k speed in OSX on a macbook?
« Last post by Macpod on January 23, 2017, 11:03:09 PM »
You can use the dummy backend (-d dummy) which will free you from being tied to an actual system. This is how I run mine.

Hope that helps!
Pages: 1 ... 8 9 [10]